BuddyBackup Forum Homepage
Forum Home Forum Home » BuddyBackup Forum » Technical issues
  New Posts New Posts RSS Feed - Renaming files in Windows Explorer
  FAQ FAQ  Forum Search   Register Register  Login Login

Renaming files in Windows Explorer

 Post Reply Post Reply
Author
Message
aidan.whitehall View Drop Down
Buddy
Buddy


Joined: 15/July/2010
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote aidan.whitehall Quote  Post ReplyReply Direct Link To This Post Topic: Renaming files in Windows Explorer
    Posted: 15/July/2010 at 10:23am
Im struggling to rename a file in a folder monitored by BuddyBackup.

Create a new file, hit F2 to rename it, start typing and after about 1 second, you receive the "are you sure you want to change the file name extension?" dialogue. If you click Yes, the file's named is changed to the incomplete file name.

Is this because Buddy Backup has detected the addition of the new file and is trying to add it to its list of files to back up, and in the process, preventing the complete entry of the new file name?
Back to Top
John View Drop Down
Admin Group
Admin Group
Avatar
Head of development

Joined: 02/May/2006
Location: United Kingdom
Status: Offline
Points: 199
Post Options Post Options   Thanks (0) Thanks(0)   Quote John Quote  Post ReplyReply Direct Link To This Post Posted: 15/July/2010 at 12:30pm
Yes, unfortunately this is a known issue.

It's partly an issue with Windows XP.

BuddyBackup spots the file and tells windows to redraw the icon showing its backup status (the red/green square). Unfortunately Windows also cancels any rename that's currently in progress.

This issue doesn't exist on Vista/7.

I'll make sure we take another look at this issue in the next update.

In the meantime, the only thing you can do is turn off Windows Explorer integration. That will solve the issue, but you'll lose the icons showing backup status.

(For this to work you need the latest version of BuddyBackup. Just exit BuddyBackup and restart it, and it will update).

To turn off Explorer integration:
  1. Open up the BuddyBackup control panel
  2. Click Tools, Options
  3. Click Advanced
  4. Click Advanced Settings
  5. Un-tick "Show icon overlays in Windows Explorer"
Regards,

John Wood
Back to Top
aidan.whitehall View Drop Down
Buddy
Buddy


Joined: 15/July/2010
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote aidan.whitehall Quote  Post ReplyReply Direct Link To This Post Posted: 15/July/2010 at 2:14pm
Originally posted by John John wrote:

Yes, unfortunately this is a known issue.

[snip]


OK, thanks for the quick reply & workaround, John.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.01
Copyright ©2001-2011 Web Wiz Ltd.